ubuntuで、ffmpeg(avconv)を使おうとしたら、Unknown encoder ‘libx264’というエラーが出た。

x264のライブラリはライセンスが絡んでいるのでデフォルトでは入らないようだ。
以下のコマンドで商用のライブラリが入って機能する。

aptitude install libavcodec-extra-53

53か52はubuntuのバージョンによって異なるようだ。